Weird printing bug

I created a disk (17 mm radius) then create a hole in it (12 mm radius) leaving a ring 5 mm ring. I am trying to design/print a part for a vacuum. I exported the STL, opened it up in Cura 5 and it looks perfect. So good I did not look at the preview. It printed a solid disk, NO 12mm hole. I then looked at the preview and yep a solid disk.

I took the STL from uMake and opened it in Blender and it looked great also.

I used blender to model the same thing, thinking a bug in Cura 5. Nope blenders looks perfect, next to the the bad one from uMake.

Any ideas what I’m doing wrong? I can share the file on GitHub, I think I can export it. I know I can share the STL file.


Update, I tried again. This time with Cura 5 and Simplifify 3d. Funny think Simplify, at least in preview, looks like it works. Cura does not

Do be clear it is the same STL file opened in both products
Ideas? I’ll include the files

Ring.stl (537.3 KB)
Ring.umk (4.1 KB)

Screen Shot 2022-06-15 at 2.52.45 PM

Just for fun I tried SuperSlicer. Same issue.
Just object on the plate

Sliced and diced NOT ready for printing.