uMake 3.10 no longer supporting iOS 12?

Latest version of uMake v3.10 keeps crashing on iOS 12 when trying to load any design, new or old.

Tested on the following devices below:
iPad 3rd Gen, iOS 12.4.1

  • Design gets to 99% completed then crashes out to the home screen.
  • I’ve tried deleting the app and re-downloading it from the App Store but without much success.

iPhone 6s. IOS 13.5

  • Design loads and works 100%

So I’m assuming this app requires iOS 13 now?

Hi Kiwi,

Thanks for letting us know about this crash. We are aware of the problem and working hard to release an update with a fix for it ASAP.
IOS 12.* is still supported for now, and hopefully you will be able to work with it really soon, however to enjoy the best experience with uMake - IOS 13.* is recommended.

Lead Developer, uMake

1 Like

Hi Yaniv,

Tried uMake ver 3.10.1 and still has the crashing issue on iOS 12

I don’t really want to, but looks like I’ll be updating to iOS 3.5 (as I’m sure it should be a lot more stable by now).

Hi Kiwi,

You are correct. The update we released seems to fix only part of iOS sub versions and it seems that with your specific version uMake still crashes. We are working to release super quick update that will fix this issue for all iOS versions. The fastest solution, that will also ensure the best experience with uMake, will be to upgrade to iOS 13.* but waiting for the update that will be released ASAP is also an option.

I am very sorry for this inconvenience,

1 Like

Thanks Yaniv,

Appreciate all the hard work and quick updates :slight_smile:


Hi @Kiwi,

We released version 3.10.2 - it might take some time until you’ll see the update on the App Store.

Please update and let us know if the issue resolved.


1 Like

Hi Evi,

I updated to uMake 3.10.2 and the designs are loading to 100% again :slight_smile:

Side note:

Another bonus is that music doesn’t stop when switching to the layers tab :smiley:

The issue with the app sometimes freezing still exists when you delete a tab from the menu (deleting from the side panel by swiping from right to left still works flawlessly so i’m using that) - but as we discovered this is an iOS 12 thing .

Keep up the good work


1 Like