A better Push and pull feature

Hi all,
I have been using the Push and pull feature for many ours now. I wish there was an easier way to create wall dimensions. Example: I created a design and then used the resolve feature, etc. and in a few minutes I had my design done. All Inneed to do is have a simple way to create a wall thickness so I can print my design on a 3D printer. The Push and Pull function works ok on objects like circles and squares easy enough. But this technique does not work on irregular shapes. If there is an easy way to do it please chim in. And please make a video.


Hi @Jmgerard,

You right, as push & pull is limited right now for flat surfaces only. That said, we’re looking into ways to allowing this feature to work on 3D surfaces, like the revolved one you created.

We hope to improve this feature sometime soon.

Thank you for your patience.


Thanks, until you update the software, are there any videos that go through creating a project that can be exported as a STL File. I can’t find anything on STL file exporting and creating for such a file format, 3D printing with current tools.


Hi again,
This time I completely started over with my design described above. This is what I tried so far…
Created a new project file
I setup project setting as mm and pincer mode activated.
Created a circle on a plain I think it is the Top view
I changed dimensions to start
I rotated the plain to enter 3D mode.
I added a surface
I then extruded the surface to create a cylinder
I went back to the top view plain and copied it
Then I resized the copy
Then I extruded copy to create a hole

At this point I can Extrude the hole all the way through the cylinder but the app does not create the hole at the bottom of the cylinder. It leaves a plain at the bottom. I have to fiddle with rotating the object trying to extrude the last part, etc. Finally I get the bottom to create the hole at the bottom. But not without work. That’s one issue.

Next, I tried changing the bottom plain dimensions to create a cone shape with walls.
I exported the design as a STL file
On my PC I use the app Sfimplify3D.
In Simplify3D the object shows a ring at the top and nothing for a part then the sides show up. If that makes any sense. My thinking right now looking at the Wireframe in UMake is that the top plain is not getting attached to the rest of the model. So, if I delete the ring in UMake you know what happens, the sides are not linked together as a wall, I think.

So, any suggestions will be appreciated, I am just working on this by trial and error since I can not find any info or vides on this workflow.


Hi @Jmgerard,

First, we will think about new tutorials revolving around 3D printing. Thanks for the suggestions! If you have ideas for something you would like to 3D print, please let me know.

Attached is a video that shows the workflow of what you’ve described. I hope that it does answer your questions:


I also opened the same geometry that I created as STL in “Ultimaker Cura”, here’s the result:

Let me know if that helps.

Thank you,

Also, here’s another way to create the same geometry, maybe even faster than the previous one I showed:


So, I created a cone shape design using the Push and Pull technique. I will attach 2 picture if Ican. What to look for is on the skinny end of the model if you zoom into the pic, you should be able to see where the wall of the part that I made in U make. The problem now is that Simply3D added interior fill which does not show in the UMake design. Right now I don’t know if there is something wrong with the UMake STL file of a setting in my slicer app Simplify3D. If I can figure that out then the Push and Pull function would be at least usable for now… I will check out your second video on Ultimaker slicer app to se if that helps.

Thank you for any help,

@Jmgerard from a first look, it looks like a issue in Simplify3D… would need to see screenshots from Simplify3D to understand what caused this issue. Maybe the surface is too thin for the printer so it added a few layers to avoid “braking the model”?

So, I etried many times to go through step by step dublicating the video about Push and Pull to make a cone shape. I am going to reply 3 times because I can only attach one picture screen shot at a time. I can’t get my version of UMake to work as the parts of the video shown in the screen shots. One, If I fiddle with things I can reproduce the rest of the video when I resize the plain and create the cone shape. That works. Creating the initial hole in the initial plain surface does not work as shown in the video. I wish it worked that easily. What I have to do is the following…
1 Create the first circle on the initial top view plain
2 copy and resize the circle
3. here I can’t perform the next step which is to turn the center circle into a hole on said plain. This look easy but I can not get this to work at all. I tried and tried with no luck. What I have to do is push pull the bigger circle plain. Then push pull the smaller middle circle plain and that creates a hold in the top. But will not create a hole in the bottom with one continuous push/drag. Then I have to rotate the 3D view to the bottom and push pull the small circle a few times on the bottom until the app finally clicks and create the hole in the bottom. Then I can go to the top plain, resize plain to create the cone design. This way works but very confusing and hard to perform. Not anything as easy as shown in the video.
Photo 1 of 3

This is screen shot 2 of 3. Showing the steps I can not perform.

Screen shot 3 of 3

Hi @Jmgerard,

To create the hole, just double tap on the surface of the inner circle and then “Erase” from the side toolbar.

Here’s another video:


I just tried this again…
I created a simple circle on a plane.
I performed three tests. The first was to extrude the main circle.
Create another circle on the top plane the tap on the smaller circle and push and Pull the smaller circle. When I got to the bottom plane of the main biggest circle I saw the color Chang that indicated to stop at that point. Works just like the videos. This did not work before. Was there a recent update? Otherwise I don’t know what the problem was, I will keep an eye out for the issue.
Second I again created a smaller circle on the main bigger circle.
I tapped on the surface for the smaller circle. Tapped on erase in the left menu bar. This creates a whole in just that plane only. Like a sheet of paper.
I then tried to push and pull the bigger main circle and I also get a whole through the the whole circle that is now a tube shape. So that works.
I am going to try to post one picture that might show part of my problem.
In the picture I created 2 smaller circle disks one created a whole all the way through and one did not. The one that created the circle all the way through, I had turned on Auto Surface option, the other one was with auto surface turned off. That might be part of my issue. I need to test more.

I forgot to add the attached photo described above.

Thanks for the clarification, Jmgerard!

  1. When the “Auto-Surface” turned off, the relationship between the inner circle to the outer circle would be lost.

  2. When you just select the surface and delete it, it will create a cut in the surface, but to create a hole, you would need to push it through the surface.

Does that makes sense?

Also, we’re always tracking bugs related to push & pull / split and always working on fixing those, if you find any bugs like that, we will prioritize them in our future releases.

Thanks again for the feedback!